2007-06-22

Compiz + Beryl = Compiz Fusion (repository)

Note: Fusion is a new project merging Compiz with Beryl.
Screenshot:


(click to enlarge)

To install:

  1. First remove compiz and beryl.
$ sudo apt-get remove beryl*
$ sudo apt-get remove compiz*


  1. Open Terminal and edit sources.list:
$ sudo gedit /etc/apt/sources.list
  1. Add to file:
deb http://download.tuxfamily.org/3v1deb feisty eyecandy
deb-src http://download.tuxfamily.org/3v1deb feisty eyecandy
  1. Save and get back to Terminal and type:
$ wget http://download.tuxfamily.org/3v1deb/DD800CD9.gpg -O- | sudo apt-key add -
$ sudo apt-get update
$ sudo apt-get dist-upgrade
$ sudo apt-get install compiz-#gnome or kde
$ sudo apt-get install compizconfig-settings-manager
$ sudo apt-get install compizconfig-backend*
$ sudo apt-get install compiz-fusion-*
  1. Remove the existing directories
$ rm -fR ~/.beryl*
$ rm -fR ~/.emerald*
$ rm -fR ~/.compiz*
  1. Run Compiz
$ compiz --replace

Post update: 16.00 - 2007Jun25

Add Compiz Fusion to startup:
  1. Go to System » Preferences » Sessions and add:
compiz --replace

Edit: 22.00 - 2007Jun25

16 comments:

Rodrigo said...
This comment has been removed by a blog administrator.
Anonymous said...

Só para dizer: Obrigado pelo post. Ele é responsável por agora ter Compiz Fusion no meu Ubuntu.


Obrigado
Paulo Aboim Pinto
Odivelas - Portugal

uterrorista said...

De nada ;)
É bom saber que alguém lê e desfruta deste blog.

Mahyar said...

Hi,

Thanks for this.

It all looks like it's working, but when I get to the very end, I get this rubbish in Terminal:

ubuntu@Ubuntu:~$ compiz --replace
Fatal: Failed test: non-power-of-two texture support
Checks indicate that it's impossible to start compiz on your system.

I've looked everywhere for this string, including the Ubuntu Forums, to no avail. Do you know what this means?

Thanks

Mahyar

uterrorista said...

hmm. i'm looking for a solution.

what's your video chipset??

Mahyar said...

Thanks for looking for a solution.

It's a VIA VT8237RPlus chipset, or so it says in my user's guide.

The strange thing is that I can configure Compiz from my Control Centre, and I keep getting software updates for it; I just can't use it.

Mahyar

uterrorista said...

i asked for help here:
http://ubuntuforums.org/showthread.php?t=496412

I've been reading that some chipseat just don't work..

have you ever used beryl or compiz successfully?

uterrorista said...

VT8237R Plus is MOTHERBOARD..

i want to know de Video Chipset!!!

Mahyar said...
This comment has been removed by the author.
Mahyar said...

I don't know what to make of this, but here it is. I appreciate your help.

ubuntu@Ubuntu:~$ lspci
00:00.0 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.1 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.2 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. PT890 Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.7 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge
00:0f.0 IDE interface: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [KT600/K8T800/K8T890 South]
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 78)
01:00.0 VGA compatible controller: VIA Technologies, Inc. UniChrome Pro IGP (rev 01)

uterrorista said...

01:00.0 VGA compatible controller: VIA Technologies, Inc. UniChrome Pro IGP (rev 01)

»» UniChrome is your video chipseat.


after 10mins search:
https://help.ubuntu.com/community/OpenChrome

or just google by:
»» uniChrome linux drivers ubuntu
or similar

i think this should soulve the problem.

Mahyar said...

Thanks for your time. It's still not working. I still get the same message in Terminal.

I give up!

uterrorista said...

i can't help you any further. sorry.

this may be a problem with compatibility of you video chipseat.
you might considering buy a new one - they are pretty cheap on the days..

ogal said...

hi, i'm chilean and i use ubuntu. I installed compiz on my ubuntu feisty.

I got the same message that mahyar in terminal:

sebaogal@ubuntu:~$ compiz --replace
Fatal: Failed test: non-power-of-two texture support
Checks indicate that it's impossible to start compiz on your system.

I've an S3 prosavage8 KM266/KL266.

I don't understand why compiz don't works if the glxinfo output says that the Direct Rendering is activated. (you understand? i don't have a good english).

uterrorista said...

take o look at
http://www.mepislovers.org/forums/showthread.php?t=4774&page=1

uterrorista said...

full link:

http://www.mepislovers.org/
forums/showthread.php?t=4774&page=1